Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

cgi.fix_pathinfo error and Timezone problem?

I have and error here. Its say it value should be 1
cgi.fix_pathinfo "1" is recommended if AJAX is not working
But in my php.ini it is set to 1 but still i get this error? i have restarted my php service.


Also my time zone is set, but when i select my GMT +1 it still says that the clock is 13:34 when it should be 14:34 instead? I also tried for fun to just say it was +2 GMT to get the correct time, but it seems it stuck at that time zone?

Comments

  • 2 Pictures of my problems.
    timezone and cgi.JPG
    932 x 65 - 19K
    timezone.JPG
    1433 x 564 - 67K
  • I just can confirm that I have the same problem with 1.9.4-RC5. My 1.9.3 display everything correctly.
  • Funny fact is that the staff users and client email is showing the correct time. Its only the first made user that have this problem.
  • @energy version of osTicket?
    You restarted your WEBSERVER after making php config changes?
  • Im running Debian, i only restartet the web relatet services not the whole server.
  • You realize that you didn't actually answer either question right?
    Version of osTicket?
    Did you restart your WEBSERVER? (yes I mean the web server software and/or service).
  • osTicket v1.9.4-RC5  version im running :-) 

    sorry about that, didnt see the first question.
  • If you changed the php.ini and restarted the webserver (service) and it still doesn't show a check mark next to it (in admin panel -> Dashboard -> Information), then PHP thinks (and as a result osT) that it is not set.  You may have multiple php.ini files and inadvertently changed it in the wrong one.  I would check that first.
  • edited December 2016
    same problem, I am able to change timezone inside the php.ini file.
    But cgi.fix_pathinfo = 1 is not working.

    settings:
    Ubuntu 16.4
    osticket 1.10
    php7.0
    apache2

    I did a downgrade to php 5.6 and got the same problem with the cgi.fix_pathinfo.

    /etc/php/7.0/apache2/php.ini  this is the path file.
    If I change timezone and then restart my apache server. The time zone inside osticket take place.
    so Iam working with the right file.
  • @smota this thread is from 2014.  Please do not hijack and necro old threads.
This discussion has been closed.