Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Upgrade 1.6 to 1.7 Timing-Out

Hello,

I'm having issues upgrading from 1.6ST to 1.7.12.  I receive two errors (generally).

Either the installation times out and brings me back to the "Upgrade" page while it's still doing things in the database with the new upgrade message being: "[core] Migrate to database-backed sessions (finished)".  Clicking the upgrade button again when on this screen does do things in the database, but isn't doing anything of substance and never completes.  I never get to the step where it sucks in the attachments and adds them to the database (though I was able to get there in other tests).

Sometimes I get the error: "upgrade group_dept_access doesn't exist" and it fails completely.

Sometimes (in tests, when it unfortunately didn't count) the upgrade proceeded successfully... I believe the page may be "timing-out" before it has a chance to finish the upgrade completely.

Can anyone assist on how to increase the time-out time for the upgrade page/process?  Or any other tips on how to avoid these errors?  Again, this is happening all the time now, but I was able to successfully kick-off the process at least once.
Thank you

Mail Sending: SMTP

Mail Fetching/Receiving: POP Gmail
PHP version: 5.3.28
Operating System: Windows Server 2008 R2 Datacenter (IIS)

Comments

  • PHP's time out is controlled by a setting in the PHP.ini.

    Look at max_execution_time and set_time_limit.

    see:
    http://php.net/manual/en/info.configuration.php#ini.max-execution-time
    and
    http://php.net/manual/en/function.set-time-limit.php


    After a failed upgrade attempt, I would recommend that you restore your DB from your back up before trying again.
  • ntozier,

    Thank you for the information.  I'm still having issues - even setting max times to huge, the updater "popup" window still closes before the query in the database is done.

    Here is a screenshot of what the database looks like when the updater window closes:
    image
    Then the upgrader shows this:
    image
    Then pressing update again gives this over and over:
    image


    Any idea what is happening and how I can correct it?  Greatly appreciated!
  • You could try upgrading from 1.6ST to 1.7ST (1.7.0) and then to 1.7.12.

  • Hi Ntozier,

    I've tried 1.7 and 1.7.12, and both seem to "time out" before finishing, even though the database continues to send data far after the page finishes.  Any other tips or tricks in upgrading?  Can't move past this step in the upgrade.
  • I have never had a problem with this, so I'm not real sure what to tell you. 
    How large is your database?
    Are you actually getting a php error (timeout)?
  • No PHP error - the "upgrading" popup on the page just closes and gives the message "[core] Migrate to database-backed sessions (finished)" when trying to upgrade to 1.7.12 or to the same "upgrade popup" message on 1.7. 

    Database is very large.

    When the popup window closes, the database remains actually running an upgrade query for about 10 minutes after... is there something that would prompt the ticket system to stop attempting the upgrade if active for "X" amount of time?

    Thank you!!
  • I think this may be getting stuck on upgrade abe9c0cb... the database takes a long time on "Insert Into 'ost_ticket_email_info'" and seemingly times out.  That's my guess as sometimes the upgrader will come back to try to upgrade this patch again.  Is there anything in abe9c0cb that I could extend?
  • Yep - it's the amount of tickets in our system.  I just culled a bunch of tickets in our test database and tried again - worked perfectly.  Is there any way to end the time-out of 1.7?  I don't think it's being forced to quit because of the PHP files.

    Thank you!!
  • I'm pretty sure that 1.7 is no longer supported at this point.  So... I'm not sure.
  • I'm trying to get to 1.9, but it won't let me upgrade unless I go through 1.7 :(
Sign In or Register to comment.