Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

osTicket v1.10 (stable) and Maintenance Release v1.9.15 are now available! Go get it now

Cursor looses focus when using backspace

This is happening at least since the latest 2 versions, so version 1.9.12 and the one before.

When I reply to a ticket and make a type and use the backspace to correct it, in 70-80% of the times, the cursor looses focus.

For example I type:
Hello customer, thiz is my

And I hit backspace because I want to change "thiz" to "this", then cursor looses focus, sometimes the y gets wiped, but then I'm hitting backspace and nothing is happening anymore.
I have to set the cursor with the mouse next to the m or y again and then use backups again and then it works as it should be.

This is very irritating. Especially if you have typed more alinea's and make corrections in a higher alinea. Sometimes when hitting backspace the cursor jumps out of focus to a lower line and characters there are getting deleted, instead of at the place you were working with the cursor.

As said, this was not happening before, only since the last 2 maybe 3 versions.

What can be causing this and can this be fixed?


  • I have the same problem. Any idea?
  • I'm already glad I'm not the only one. Today the cursor even jumped to the top of the reply.

  • Seems to be a problem with new firefox versions and the used redactor version. 

    A newer redactor version (which will come with 1.10) could solve this:

    As a workaround you could to try to set a higher value for the autosave and see if it helps:

    Some other had used the firefox addon noscript (see issue 2373 on github) but I don't know if this a good idea..
  • edited August 2015
    Oke I indeed use Firefox (40.0.2) and at this moment I set the autosave to 30, we will see if it helps.
    Hopefully the 1.10 redactor will indeed fix it.

    Thank you!
  • If draft saving gives you more problems then joy....just change line 17 of  js/redactor-osticket.js from

    if (!this.opts.draftNamespace)


    if (this.opts.draftNamespace)
    console.log('Drafts are killed because of cursor issues');
  • Thank you bxck75.
    I did not have any benefit of changing autosave to 30. What was the original autosave setting?
  • This is an issue with the redactor RTE:

    It's fixed in redactor v10.2.3:

    "[Fixed] Issue in Firefox when in linebreaks mode using Backspace lead sometimes to cursor disappearance"

    It looks like redactor v9.2.4 is packaged with osticket v1.9.12 - hopefully they'll get it upgraded soon.
  • Yes Rajahd thank you, but we already know, mfelber pointed it out to us a bit earlier in this thread. We're just looking for a good workaround for the time being until the update is released.
  • Oops sorry I misread mfelber's post.  I plead insanity as this issue is driving me nuts when replying to tickets ;)
  • No problem mate. We can shake hands, replying to tickets is driving me nuts too. :D
  • Any news about this?

    I've the same problem with the 1.9.12 version of osTicket...
  • As we have trouble with this as well, is there any proper solution in sight? Will the redactor be updated in the coming version?
  • edited February 2016
    The problem is that if we are using the system with our company, we can't say "it receives update in the new version" because we don't know when the new version will be released.

    We need ETA because it's important for us know when all the fixes (and not only this) will be releases.
  • @rotelocke  and @davideakc There are something like 3 fixes listed in this thread. 
    Did you actually try any of them?
    Post 4, two fixes.
    Post 6, one fix

  • In fact it is Post 3 and post 5 and they both contain only 1 workaround, not a fix.
    In post 3 the first thing is only a link to the github bug report which does not has a fix or workaround.
    The second workaround does not help, so in fact there is only 1 workaround which is the one in post 5.
    Which means editting core files which I normally don't like so I didn't test that.

    We appreciate all the work the team puts in ofcourse. But I agree it just would be nice if there would be some ETA or approximate date people are thinking of, because there is 0 news after 7 months now about any kind of update. That's a bit of a long time.;)

  • Post 4 by MFelber.
    fix 1: upgrade your version of Redactor (or upgrade to the rc2 which I wouldn't recommend)
    fix 2: set a higher value for the autosave

    Post 6 by bxck75
    fix 1: edit
  • edited February 2016
    How we can update Redactor?
  • edited February 2016
    @Ntozier: I don't know where you're counting from, but xavirietis is post 1, so MFelber is post 3 and bxck75 is post 5.
    At the first it said "only a new reactor could solve this". "Could" is not being sure, so no definate fix statement imho.

    But oke, in this case only the first is a fix, both others are workarounds and as I said "fix 2" makes no difference fixes nothing, tried that already, same problem.

    Anyway I also would like to know how we can update redactor, because I guess most of us don't know how to do that.
  • @ntozier
    Tried everything but to update redactor and to no avail. Updating that seemed to me to be out of the question as the post suggested this to be part of a new release. I have no idea how deeply embeded this is in the system, so this would need some looking into..
    Has anyone done this or looked deeper into this? We're running Version 1.9.12 currently and have no intentions on updating to an RC on a productive system.
  • @rotelocke you're right, we can't use a beta version...

    I will look into it more closely tommorrow :)
  • edited March 2016
    @davideakc much appreciated, really busy on another front at the matter or I'd do it myself. Please post if you find out anything useful - thanks.

    Also: Where should we get a new version of redactor from? From what I read on their website it costs $1495 for the appropriate license. At least I couldn't find another open-source download on my brief look around.
  • @NTozier: My apology, you were right, it was reply 3 and 5 but post 4 and 6 as you said. ;)
    However, the github link does only suggest the replacement of the redactor, not the how to replace it so it's not a fix because as you can't see people don't have a clue how.

  • edited March 2016
    I haven't found a solution for this

    I think the only solution is to wait the 1.10 version of osTicket with impatiently
  • Has anyone found a workaround to this ? Been getting complaints from my boss who says he will never switch browsers....
  • edited April 2016
    @HirenBudhrani have you tried to disable the autosave drafts?

    With that function disabled, I've fixed the problem at 90%
  • Well I set the autosaveInterval to 500. How do I completely disable it ?
  • You need to edit the file /js/redactor-osticket.js:

     this.$draft_saved = $('<span>')
                .addClass("pull-right draft-saved")
                    //.text(__('Draft Saved')));
            // Float the [Draft Saved] box with the toolbar
            if (this.opts.draftDelete) {
                var trash = this.buttonAdd('deleteDraft', __('Delete Draft'), this.deleteDraft);
                this.buttonAwesome('deleteDraft', 'icon-trash');

    Tell me if it works :)
  • Well I'm using the newest version 1.10 now and it still is not fixed. :(
    Still having issues.
  • Anyone else still having this issue?
    osTicket Version     v1.10 (901e5ea) — Up to date
    Web Server Software     Apache/2
    MySQL Version     5.5.53
    PHP Version     5.6.30
  • @Richard63 Did you try any of the three fixes in this thread?
Sign In or Register to comment.